安装Everpad--未满足的依赖--libgtk2.0-0(=2.24.23-0ubuntu1),但2.24.23-0ubuntu1.1要安装

Install Everpad - unmet dependencies - libgtk2.0-0 (= 2.24.23-0ubuntu1) but 2.24.23-0ubuntu1.1 is to be installed


问题

我对Ubuntu很陌生,但很想掌握它。我试图在Ubuntu 14.04上安装Everpad。仓库被添加到source.list,仓库的密钥也被注册。

有一个未满足的依赖关系。有什么办法可以让我解决libgtk2.0-0的问题吗?到目前为止,我没有强迫apt-get安装everpad而不考虑缺失的依赖性。

我的Ubuntu每天都在更新,我没有在aptitude中保护libgtk2.0-0不被更新。

$ sudo apt-get install everpad
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
everpad : Depends: gtk2-engines-pixbuf but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

$ sudo apt-get install gtk2-engines-pixbuf
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
 gtk2-engines-pixbuf : Depends: libgtk2.0-0 (= 2.24.23-0ubuntu1) but  
2.24.23-0ubuntu1.1 is to be installed
E: Unable to correct problems, you have held broken packages.

$ sudo apt-get install libgtk2.0-0
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libgtk2.0-0 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
也许你需要安装gtk2-engines-pixbuf(2.24.23-0ubuntu1.3) packages.ubuntu.com/trusty-updates/gtk2-engines-pixbuf
你最近是否运行了 sudo apt-get update
答案1

我用aptitude降级了4个库,解决了依赖性问题。Aptitude会显示问题的解决方案,接受降级的那一个就解决了。

这里有更多关于aptitude的信息 一般aptitude的操作指南

Everpad现在工作正常了。

你降级了哪些软件包?
答案2

我最近遇到了同样的问题。 我发现我必须在软件更新(更新标签)中启用推荐更新(ubuntu 14.04中的trusty-updates)。 这使得系统能够下载最新版本的软件包;